re = /<([^>]+)>/
str = '"Meu nome <meuNome@email.com.br>";
"Meu nome <meuNome@email.com>";
"Meu nome <a@b.com.br>";
"Meu nome <teste de conteudo>";
"Meu nome <testede@conteudo>";
"Meu nome <var1>var2>";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end