package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<(.*)>`)
var str = `"Meu nome <meuNome@email.com.br>";
"Meu nome <meuNome@email.com>";
"Meu nome <a@b.com.br>";
"Meu nome <teste de conteudo>";
"Meu nome <testede@conteudo>";
"Meu nome <var1>var2>";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}