package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^[а-яё\d\s\p{P}]*[\d]+[а-яё\d\s\p{P}]*$`)
var str = `1ыва.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}