const regex = /^[а-яё\d\s\p{P}]*[\d]+[а-яё\d\s\p{P}]*$/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[а-яё\\d\\s\\p{P}]*[\\d]+[а-яё\\d\\s\\p{P}]*$', 'gi')
const str = `1ыва.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}