$re = '/^[а-яё\d\s\p{P}]*[\d]+[а-яё\d\s\p{P}]*$/i';
$str = '1ыва.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);