#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\$\r?\n)|\r?\n"
Local $sString = "1598356988 228938 90 18 $$$" & @CRLF & _
"1598356994 228548 90 1031 $$$" & @CRLF & _
"1598357029 229550 90 751 $$$" & @CRLF & _
"1598357031 228916 89 586 Частичное подтверждение:" & @CRLF & _
"2020-08-20 02:24 = 4л.;" & @CRLF & _
"2020-08-19 02:46 = 4л.;" & @CRLF & _
"" & @CRLF & _
"$$$" & @CRLF & _
"1598357036 229337 90 5 $$$" & @CRLF & _
"1598357079 229054 90 586 $$$" & @CRLF & _
"1598357092 228547 90 1031 $$$" & @CRLF & _
"1598357092 229053 90 586 $$$" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)