import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\$\\r?\\n)|\\r?\\n";
final String string = "1598356988 228938 90 18 $$$\n"
+ "1598356994 228548 90 1031 $$$\n"
+ "1598357029 229550 90 751 $$$\n"
+ "1598357031 228916 89 586 Частичное подтверждение:\n"
+ "2020-08-20 02:24 = 4л.;\n"
+ "2020-08-19 02:46 = 4л.;\n\n"
+ "$$$\n"
+ "1598357036 229337 90 5 $$$\n"
+ "1598357079 229054 90 586 $$$\n"
+ "1598357092 228547 90 1031 $$$\n"
+ "1598357092 229053 90 586 $$$\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}