$re = '/(\$\r?\n)|\r?\n/';
$str = '1598356988 228938 90 18 $$$
1598356994 228548 90 1031 $$$
1598357029 229550 90 751 $$$
1598357031 228916 89 586 Частичное подтверждение:
2020-08-20 02:24 = 4л.;
2020-08-19 02:46 = 4л.;
$$$
1598357036 229337 90 5 $$$
1598357079 229054 90 586 $$$
1598357092 228547 90 1031 $$$
1598357092 229053 90 586 $$$
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;