using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/#\s*((?:.|\n)*?)\s*#\/";
string input = @"Hello
/# my name
is
Mike
nice to meet you
#/
aoeuoaeu /#
multi-line
#/
/# single-line #/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}