// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/#\s*((?:.|\n)*?)\s*#\/").unwrap();
let string = "Hello
/# my name
is
Mike
nice to meet you
#/
aoeuoaeu /#
multi-line
#/
/# single-line #/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}