package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(@[\w ]+):user:(\d+)`)
var str = `[@he man:user:123] [@super man:user:456] [@bat man:user:789]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}