re = /(@[\w ]+):user:(\d+)/m
str = '[@he man:user:123] [@super man:user:456] [@bat man:user:789]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end