$re = '/(@[\w ]+):user:(\d+)/m';
$str = '[@he man:user:123] [@super man:user:456] [@bat man:user:789]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);