import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0((13|2[2-4]|3|4[05-8]|5[05]|6[24-689]|8[2468]|9[235-7])\\d{7}|1[0125]\\d{8})$";
final String string = "0237802486\n"
+ "0237794824\n"
+ "0225292828\n"
+ "0222803359\n"
+ "0244672263\n"
+ "0683362700\n"
+ "0927922556\n"
+ "01020304050\n"
+ "01177777777\n"
+ "01234567890\n"
+ "01018028445\n"
+ "01015030111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}