import re
regex = re.compile(r"^0((13|2[2-4]|3|4[05-8]|5[05]|6[24-689]|8[2468]|9[235-7])\d{7}|1[0125]\d{8})$", flags=re.MULTILINE)
test_str = ("0237802486\n"
"0237794824\n"
"0225292828\n"
"0222803359\n"
"0244672263\n"
"0683362700\n"
"0927922556\n"
"01020304050\n"
"01177777777\n"
"01234567890\n"
"01018028445\n"
"01015030111")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")