package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^((?:[_a-z])\w{0,31})\s*$|^.*$`)
var str = `Valid cases are green:
PARAMETER_NAME
HELLO_WORLD
hello_word
_new_
_999_
_asdkj123123123asdasd12312312312
_I_am_a_32_characters_long_name
__hello
_____
Invalid cases are not green:
9asdaudqwudhquwdhquwd
_I_am_a_33_characters_long_string
Valid SAS names:
First character is an underscore or an English letter
Followed by any combination of underscores, English letters and numbers
Max 32 characters long`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}