# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?:[_a-z])\w{0,31})\s*$|^.*$"
test_str = ("Valid cases are green:\n"
"PARAMETER_NAME\n"
"HELLO_WORLD\n"
"hello_word\n"
"_new_\n"
"_999_\n"
"_asdkj123123123asdasd12312312312\n"
"_I_am_a_32_characters_long_name\n"
"__hello\n"
"_____\n\n"
"Invalid cases are not green:\n"
"9asdaudqwudhquwdhquwd\n"
"_I_am_a_33_characters_long_string\n\n\n"
"Valid SAS names:\n"
"First character is an underscore or an English letter\n"
"Followed by any combination of underscores, English letters and numbers\n"
"Max 32 characters long")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.