using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^>]*href=\""([^\""]+)\""(?:(?! data-(?:survey=|answer=)).)*( data-survey=[\""\']({[^}]*})[\""\'])?( data-answer=[\""\']({[^}]*})[\""\'])?[^>]*\/?>";
string input = @"<a href=""#"" foo data-survey=""{...}"">
<a href=""#"" foo data-answer=""{...}"">
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}