re = /<a[^>]*href=\"([^\"]+)\"(?:(?! data-(?:survey=|answer=)).)*( data-survey=[\"\']({[^}]*})[\"\'])?( data-answer=[\"\']({[^}]*})[\"\'])?[^>]*\/?>/
str = '<a href="#" foo data-survey="{...}">
<a href="#" foo data-answer="{...}">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end