$re = '/<a[^>]*href=\"([^\"]+)\"(?:(?! data-(?:survey=|answer=)).)*( data-survey=[\"\']({[^}]*})[\"\'])?( data-answer=[\"\']({[^}]*})[\"\'])?[^>]*\/?>/';
$str = '<a href="#" foo data-survey="{...}">
<a href="#" foo data-answer="{...}">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);