#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Linus::.*?(?=::(?!CASE\b)|$)"
Local $sString = "Linus::AOPKNS::CASE" & @CRLF & _
"Linus::AOPKNS" & @CRLF & _
"Linus::AOPKNS::OK" & @CRLF & _
"Linus::AOPKNS::A::CASE" & @CRLF & _
"Linus::AOPKNS::CASE::A" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")