import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Linus::.*?(?=::(?!CASE\\b)|$)";
final String string = "Linus::AOPKNS::CASE\n"
+ "Linus::AOPKNS\n"
+ "Linus::AOPKNS::OK\n"
+ "Linus::AOPKNS::A::CASE\n"
+ "Linus::AOPKNS::CASE::A\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}