$re = '/^Linus::.*?(?=::(?!CASE\b)|$)/m';
$str = 'Linus::AOPKNS::CASE
Linus::AOPKNS
Linus::AOPKNS::OK
Linus::AOPKNS::A::CASE
Linus::AOPKNS::CASE::A
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);