const regex = /(?=(?'a'[\s\S]*))(?'b'X(?=\k'a'\z)|(?<=(?=x^|(?&b))[\s\S]))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(?\'a\'[\\s\\S]*))(?\'b\'X(?=\\k\'a\'\\z)|(?<=(?=x^|(?&b))[\\s\\S]))', '')
const str = `bla X bla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}