$re = '/(?=(?\'a\'[\s\S]*))(?\'b\'X(?=\k\'a\'\z)|(?<=(?=x^|(?&b))[\s\S]))/';
$str = 'bla X bla';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);