$re = '/<text[^<>]*?>\s*<original><!\[CDATA\[[^\[\]]*?\]\]><\/original>\s*<replacement><!\[CDATA\[[^\[\]]*?[а-я][^\[\]]*?\]\]><\/replacement>\s*<\/text>\s*/iusm';
$str = '<text autoId=“1” alias=“Achieve.Name_955_collect_Costume_TournamentRanking30_step1” priority=“0”>
<original><![CDATA[比武胜利者]]></original>
<replacement><![CDATA[Опытный дуэлянт]]></replacement>
</text>
<text autoId=“2” alias=“Achieve.Name_955_collect_Costume_TournamentRanking30_step2” priority=“0”>
<original><![CDATA[比武胜利者]]></original>
<replacement><![CDATA[比武胜利者]]></replacement>
</text>
<text autoId=“3” alias=“Achieve.Name_955_collect_Costume_TournamentRanking30_step3” priority=“0”>
<original><![CDATA[比武胜利者]]></original>
<replacement><![CDATA[Опытный дуэлянт]]></replacement>
</text>
<text autoId=“4” alias=“Achieve.Name_955_collect_Costume_TournamentRanking30_step4” priority=“0”>
<original><![CDATA[比武胜利者]]></original>
<replacement><![CDATA[Опытный дуэлянт]]></replacement>
</text>
<text autoId=“5” alias=“Achieve.Name_955_collect_Costume_TournamentRanking30_step5” priority=“0”>
<original><![CDATA[比武胜利者]]></original>
<replacement><![CDATA[Опытный дуэлянт]]></replacement>
</text>
<text autoId=“6” alias=“Achieve.Name_955_collect_Costume_TournamentRanking30_step6” priority=“0”>
<original><![CDATA[比武胜利者]]></original>
<replacement><![CDATA[比武胜利者]]></replacement>
</text>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;