# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<text[^<>]*?>\s*<original><!\[CDATA\[[^\[\]]*?\]\]><\/original>\s*<replacement><!\[CDATA\[[^\[\]]*?[а-я][^\[\]]*?\]\]><\/replacement>\s*<\/text>\s*"
test_str = ("<text autoId=“1” alias=“Achieve.Name_955_collect_Costume_TournamentRanking30_step1” priority=“0”>\n"
"<original><![CDATA[比武胜利者]]></original>\n"
"<replacement><![CDATA[Опытный дуэлянт]]></replacement>\n"
"</text>\n"
"<text autoId=“2” alias=“Achieve.Name_955_collect_Costume_TournamentRanking30_step2” priority=“0”>\n"
"<original><![CDATA[比武胜利者]]></original>\n"
"<replacement><![CDATA[比武胜利者]]></replacement>\n"
"</text>\n"
"<text autoId=“3” alias=“Achieve.Name_955_collect_Costume_TournamentRanking30_step3” priority=“0”>\n"
"<original><![CDATA[比武胜利者]]></original>\n"
"<replacement><![CDATA[Опытный дуэлянт]]></replacement>\n"
"</text>\n"
"<text autoId=“4” alias=“Achieve.Name_955_collect_Costume_TournamentRanking30_step4” priority=“0”>\n"
"<original><![CDATA[比武胜利者]]></original>\n"
"<replacement><![CDATA[Опытный дуэлянт]]></replacement>\n"
"</text>\n"
"<text autoId=“5” alias=“Achieve.Name_955_collect_Costume_TournamentRanking30_step5” priority=“0”>\n"
"<original><![CDATA[比武胜利者]]></original>\n"
"<replacement><![CDATA[Опытный дуэлянт]]></replacement>\n"
"</text>\n"
"<text autoId=“6” alias=“Achieve.Name_955_collect_Costume_TournamentRanking30_step6” priority=“0”>\n"
"<original><![CDATA[比武胜利者]]></original>\n"
"<replacement><![CDATA[比武胜利者]]></replacement>\n"
"</text>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.UNICODE | re.DOTALL | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.