#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "A(.)B\1"
Local $sString = "AnBn"
Local $sSubst = "$0$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)