using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"A(.)B\1";
string substitution = @"$0$0";
string input = @"AnBn";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}