use strict;
my $str = 'AnBn';
my $regex = qr/A(.)B\1/p;
my $subst = '$0$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";