using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""name"">(.+)<.+""value"">(.+)<";
string input = @"<h3></h3>
<dl class=""data"">
<dt class=""name"">Поле1</dt>
<dd class=""value"">Поле1_1</dd>
<dt class=""name"">Поле2</dt>
<dd class=""value"">Поле2_2</dd>
</dl>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}