re = /"name">(.+)<.+"value">(.+)</i
str = '<h3></h3>
<dl class="data">
<dt class="name">Поле1</dt>
<dd class="value">Поле1_1</dd>
<dt class="name">Поле2</dt>
<dd class="value">Поле2_2</dd>
</dl>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end