#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s-i)\A(?!.*\QCopyright MyCompany Ltd. All Rights Reserved\E).+"
Local $sString = "// Just add a typo to the copyright text below for the regex to pick it up." & @CRLF & _
"// JetBrains Rider uses .PCRE2 regex." & @CRLF & _
"/********************************************************" & @CRLF & _
"* Copyright MyCompany Ltd. All Rights Reserved *" & @CRLF & _
"*********************************************************/" & @CRLF & _
"#pragma once" & @CRLF & _
"" & @CRLF & _
"insert code here"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")