re = /(?s-i)\A(?!.*\QCopyright MyCompany Ltd. All Rights Reserved\E).+/m
str = '// Just add a typo to the copyright text below for the regex to pick it up.
// JetBrains Rider uses .PCRE2 regex.
/********************************************************
* Copyright MyCompany Ltd. All Rights Reserved *
*********************************************************/
#pragma once
insert code here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end