using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s-i)\A(?!.*\QCopyright MyCompany Ltd. All Rights Reserved\E).+";
string input = @"// Just add a typo to the copyright text below for the regex to pick it up.
// JetBrains Rider uses .PCRE2 regex.
/********************************************************
* Copyright MyCompany Ltd. All Rights Reserved *
*********************************************************/
#pragma once
insert code here";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}