package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\d{4}-\d{2}-\d{2})(?:,\s*(?1))*$`)
var str = `2016-10-02,2016-10-13, 2016-10-25`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}