re = /^(\d{4}-\d{2}-\d{2})(?:,\s*(?1))*$/
str = '2016-10-02,2016-10-13, 2016-10-25'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end