$re = '/^(\d{4}-\d{2}-\d{2})(?:,\s*(?1))*$/';
$str = '2016-10-02,2016-10-13, 2016-10-25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);