use strict;
my $str = '/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can\'t extract from the format
* @returns {any} - the default value or extracted format value
*/
const a = {
apples() {
},
apples2 : function() {
},
apples3 : () => {
}
}
function(){}
function() {}
function() { }
function () { }
function (arg, asdf) { }
function (arg, asdf):Typings { }
function (arg, asdf):something<Else> { }
function () { }
const x = function () { }
const { x } = function () { }
const { x: asdf } = function () { }
const filterFn = () => {}
// won\'t grab
const filterFn = apples.filter(() => {});
// won\'t grab
const filterFn = apples.filter(function(){});
class Bla {
constructor() {
}
someMethod1() {
}
someMethod2() => {
}
get someMethod3() {
}
}
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can\'t extract from the format
* @returns {any} - the default value or extracted format value
*/
HoverBoard.prototype.getFormatValueIfExists = function (prop, defaultValue) {
try {
return typeof this.config.formats[this.name][prop] !== \'undefined\' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can\'t extract from the format
* @returns {any} - the default value or extracted format value
*/
const getFormatValueIfExists = function (prop, defaultValue) {
try {
return typeof this.config.formats[this.name][prop] !== \'undefined\' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can\'t extract from the format
* @returns {any} - the default value or extracted format value
*/
var getFormatValueIfExists = (prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== \'undefined\' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can\'t extract from the format
* @returns {any} - the default value or extracted format value
*/
window.x = (prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== \'undefined\' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can\'t extract from the format
* @returns {any} - the default value or extracted format value
*/
something.else.x = (prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== \'undefined\' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can\'t extract from the format
* @returns {any} - the default value or extracted format value
*/
var x = null;
x = (prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== \'undefined\' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can\'t extract from the format
* @returns {any} - the default value or extracted format value
*/
function getFormatValueIfExists(prop, defaultValue) {
try {
return typeof this.config.formats[this.name][prop] !== \'undefined\' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can\'t extract from the format
* @returns {any} - the default value or extracted format value
*/
function (prop, defaultValue) {
try {
return typeof this.config.formats[this.name][prop] !== \'undefined\' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can\'t extract from the format
* @returns {any} - the default value or extracted format value
*/
(prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== \'undefined\' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can\'t extract from the format
* @returns {any} - the default value or extracted format value
*/
((prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== \'undefined\' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
}());
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can\'t extract from the format
* @returns {any} - the default value or extracted format value
*/
((prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== \'undefined\' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
} (window) );
';
my $regex = qr/^(\/\*\*(?:(?:\S|\s)(?!\*\/))*?(?:\S|\s)?\*\/\s*)?((?:(?:const|var|let).*{.*})?[^}\n]*(?:\(.*\).*{))/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}