# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\/\*\*(?:(?:\S|\s)(?!\*\/))*?(?:\S|\s)?\*\/\s*)?((?:(?:const|var|let).*{.*})?[^}\n]*(?:\(.*\).*{))"
test_str = ("/**\n"
" * @function\n"
" * @description simple method that tries to retrieve a config value from the format\n"
" * if it exists, else it will return the second argument as the default value.\n"
" * @param {string} prop - the prop name to retrieve\n"
" * @param {any} defaultValue - the value to use if we can't extract from the format\n"
" * @returns {any} - the default value or extracted format value\n"
" */\n\n"
"const a = {\n"
" apples() {\n\n"
" },\n"
" apples2 : function() {\n"
" },\n"
" apples3 : () => {\n"
" }\n"
"}\n\n"
"function(){}\n\n"
"function() {}\n\n"
"function() { }\n\n"
"function () { }\n"
"function (arg, asdf) { }\n"
"function (arg, asdf):Typings { }\n"
"function (arg, asdf):something<Else> { }\n\n"
"function () { }\n"
"const x = function () { }\n"
"const { x } = function () { }\n\n"
"const { x: asdf } = function () { }\n\n"
"const filterFn = () => {}\n\n"
"// won't grab\n"
"const filterFn = apples.filter(() => {});\n"
"// won't grab\n"
"const filterFn = apples.filter(function(){});\n\n\n\n"
"class Bla {\n"
" constructor() {\n"
" }\n"
" someMethod1() {\n"
" }\n"
" someMethod2() => {\n"
" }\n"
" get someMethod3() {\n"
" }\n"
"}\n\n\n"
"/**\n"
" * @function\n"
" * @description simple method that tries to retrieve a config value from the format\n"
" * if it exists, else it will return the second argument as the default value.\n"
" * @param {string} prop - the prop name to retrieve\n"
" * @param {any} defaultValue - the value to use if we can't extract from the format\n"
" * @returns {any} - the default value or extracted format value\n"
" */\n"
"HoverBoard.prototype.getFormatValueIfExists = function (prop, defaultValue) {\n"
" try {\n"
" return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;\n"
" } catch (e) {\n"
" return defaultValue;\n"
" }\n"
"};\n\n"
"/**\n"
" * @function\n"
" * @description simple method that tries to retrieve a config value from the format\n"
" * if it exists, else it will return the second argument as the default value.\n"
" * @param {string} prop - the prop name to retrieve\n"
" * @param {any} defaultValue - the value to use if we can't extract from the format\n"
" * @returns {any} - the default value or extracted format value\n"
" */\n"
"const getFormatValueIfExists = function (prop, defaultValue) {\n"
" try {\n"
" return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;\n"
" } catch (e) {\n"
" return defaultValue;\n"
" }\n"
"};\n\n"
"/**\n"
" * @function\n"
" * @description simple method that tries to retrieve a config value from the format\n"
" * if it exists, else it will return the second argument as the default value.\n"
" * @param {string} prop - the prop name to retrieve\n"
" * @param {any} defaultValue - the value to use if we can't extract from the format\n"
" * @returns {any} - the default value or extracted format value\n"
" */\n"
" var getFormatValueIfExists = (prop, defaultValue) => {\n"
" try {\n"
" return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;\n"
" } catch (e) {\n"
" return defaultValue;\n"
" }\n"
"};\n\n"
"/**\n"
" * @function\n"
" * @description simple method that tries to retrieve a config value from the format\n"
" * if it exists, else it will return the second argument as the default value.\n"
" * @param {string} prop - the prop name to retrieve\n"
" * @param {any} defaultValue - the value to use if we can't extract from the format\n"
" * @returns {any} - the default value or extracted format value\n"
" */\n"
"window.x = (prop, defaultValue) => {\n"
" try {\n"
" return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;\n"
" } catch (e) {\n"
" return defaultValue;\n"
" }\n"
"};\n\n"
"/**\n"
" * @function\n"
" * @description simple method that tries to retrieve a config value from the format\n"
" * if it exists, else it will return the second argument as the default value.\n"
" * @param {string} prop - the prop name to retrieve\n"
" * @param {any} defaultValue - the value to use if we can't extract from the format\n"
" * @returns {any} - the default value or extracted format value\n"
" */\n"
"something.else.x = (prop, defaultValue) => {\n"
" try {\n"
" return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;\n"
" } catch (e) {\n"
" return defaultValue;\n"
" }\n"
"};\n\n\n"
"/**\n"
" * @function\n"
" * @description simple method that tries to retrieve a config value from the format\n"
" * if it exists, else it will return the second argument as the default value.\n"
" * @param {string} prop - the prop name to retrieve\n"
" * @param {any} defaultValue - the value to use if we can't extract from the format\n"
" * @returns {any} - the default value or extracted format value\n"
" */\n"
"var x = null;\n"
"x = (prop, defaultValue) => {\n"
" try {\n"
" return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;\n"
" } catch (e) {\n"
" return defaultValue;\n"
" }\n"
"};\n\n\n"
"/**\n"
" * @function\n"
" * @description simple method that tries to retrieve a config value from the format\n"
" * if it exists, else it will return the second argument as the default value.\n"
" * @param {string} prop - the prop name to retrieve\n"
" * @param {any} defaultValue - the value to use if we can't extract from the format\n"
" * @returns {any} - the default value or extracted format value\n"
" */\n"
"function getFormatValueIfExists(prop, defaultValue) {\n"
" try {\n"
" return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;\n"
" } catch (e) {\n"
" return defaultValue;\n"
" }\n"
"};\n\n"
"/**\n"
" * @function\n"
" * @description simple method that tries to retrieve a config value from the format\n"
" * if it exists, else it will return the second argument as the default value.\n"
" * @param {string} prop - the prop name to retrieve\n"
" * @param {any} defaultValue - the value to use if we can't extract from the format\n"
" * @returns {any} - the default value or extracted format value\n"
" */\n"
"function (prop, defaultValue) {\n"
" try {\n"
" return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;\n"
" } catch (e) {\n"
" return defaultValue;\n"
" }\n"
"};\n\n"
"/**\n"
" * @function\n"
" * @description simple method that tries to retrieve a config value from the format\n"
" * if it exists, else it will return the second argument as the default value.\n"
" * @param {string} prop - the prop name to retrieve\n"
" * @param {any} defaultValue - the value to use if we can't extract from the format\n"
" * @returns {any} - the default value or extracted format value\n"
" */\n"
"(prop, defaultValue) => {\n"
" try {\n"
" return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;\n"
" } catch (e) {\n"
" return defaultValue;\n"
" }\n"
"};\n\n"
"/**\n"
" * @function\n"
" * @description simple method that tries to retrieve a config value from the format\n"
" * if it exists, else it will return the second argument as the default value.\n"
" * @param {string} prop - the prop name to retrieve\n"
" * @param {any} defaultValue - the value to use if we can't extract from the format\n"
" * @returns {any} - the default value or extracted format value\n"
" */\n"
"((prop, defaultValue) => {\n"
" try {\n"
" return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;\n"
" } catch (e) {\n"
" return defaultValue;\n"
" }\n"
"}());\n\n\n\n\n"
"/**\n"
" * @function\n"
" * @description simple method that tries to retrieve a config value from the format\n"
" * if it exists, else it will return the second argument as the default value.\n"
" * @param {string} prop - the prop name to retrieve\n"
" * @param {any} defaultValue - the value to use if we can't extract from the format\n"
" * @returns {any} - the default value or extracted format value\n"
" */\n"
"((prop, defaultValue) => {\n"
" try {\n"
" return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;\n"
" } catch (e) {\n"
" return defaultValue;\n"
" }\n"
"} (window) );\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.