import Foundation
let pattern = #"^(\/\*\*(?:(?:\S|\s)(?!\*\/))*?(?:\S|\s)?\*\/\s*)?((?:(?:const|var|let).*{.*})?[^}\n]*(?:\(.*\).*{))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
const a = {
apples() {
},
apples2 : function() {
},
apples3 : () => {
}
}
function(){}
function() {}
function() { }
function () { }
function (arg, asdf) { }
function (arg, asdf):Typings { }
function (arg, asdf):something<Else> { }
function () { }
const x = function () { }
const { x } = function () { }
const { x: asdf } = function () { }
const filterFn = () => {}
// won't grab
const filterFn = apples.filter(() => {});
// won't grab
const filterFn = apples.filter(function(){});
class Bla {
constructor() {
}
someMethod1() {
}
someMethod2() => {
}
get someMethod3() {
}
}
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
HoverBoard.prototype.getFormatValueIfExists = function (prop, defaultValue) {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
const getFormatValueIfExists = function (prop, defaultValue) {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
var getFormatValueIfExists = (prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
window.x = (prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
something.else.x = (prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
var x = null;
x = (prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
function getFormatValueIfExists(prop, defaultValue) {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
function (prop, defaultValue) {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
(prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
((prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
}());
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
((prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
} (window) );
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)