package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)article (\d+)((, \d+)* or (\d+))?`)
var str = `...as found in article 6, 7, 9, 10 or 8, depending on...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}