const regex = /article (\d+)((, \d+)* or (\d+))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('article (\\d+)((, \\d+)* or (\\d+))?', 'gm')
const str = `...as found in article 6, 7, 9, 10 or 8, depending on...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}