$re = '/article (\d+)((, \d+)* or (\d+))?/m';
$str = '...as found in article 6, 7, 9, 10 or 8, depending on...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);