package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+(?:\.+\w+)+`)
var str = `this is an example test.abc.123 for what I am looking for
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}