$re = '/\w+(?:\.+\w+)+/m';
$str = 'this is an example test.abc.123 for what I am looking for
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);