re = /\w+(?:\.+\w+)+/m
str = 'this is an example test.abc.123 for what I am looking for
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end