package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\p{L}\p{N}]+`)
var str = `J&öfá44`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}