use strict;
my $str = 'J&öfá44';
my $regex = qr/[^\p{L}\p{N}]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";