use strict;
my $str = '45.09 y';
my $regex = qr/^(\d+\.\d+).*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";